Frida-ios-dump 报错ImportError: No module named paramiko


#1

求教,我在执行./dump.py的时候报错ImportError: No module named paramiko,python当前版本是2.7.1的,谢谢


#2

下载依赖 按照readme去做


#3

我安装了的,只是我安装的是在chsh -s /bin/bash环境里 ,
Xnip2019-05-06_10-56-03


#4

那你source一下 bash的环境变量 或者 用python3的版本吧


#5

我source了的


#6

Xnip2019-05-06_16-55-38


#7

这个执行了吗?

sudo pip install -r requirements.txt --upgrade

node环境如果好用,可以试试这个哈哈


#8

Xnip2019-05-06_10-49-26


#9

输入你的密码


#10

不是输入密码的问题,我前面已经装过了,我的python的版本是2.7.1,
sudo pip install -r requirements.txt --upgrade ,会报错

我的python版本是2.7.1,按照 Frida-ios-dump 作者的文档,应该是输入sudo pip install -r requirements.txt --upgrade (Python 2.7),但是还是不行


#11

看提示用这个sudo pip install -r requirements.txt --upgrade --user