[求助]升级 macOS Sonoma + Xcode15 后使用 monkeydev 编译报错

https://github.com/suifengFly1/MonkeyDev.git
你们的问题都解决了。

1 个赞

没找到对应目录 您能提供下吗

你解决了没?我已经通过另类的方法解决了。
在网上下一个xcode14.3.1,然后在/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain目录下把这个XcodeDefault.xctoolchain复制到xcode15的同目录下,然后把15的XcodeDefault.xctoolchain改名就可以解决了,如果要用15的XcodeDefault.xctoolchain可以通过再次改名来使用。

我测试了 未解决 iPhoneos 这个识别不了,tewek和MonkeyDev创建新项目报的还是一样

我试下您的方式

确实可以

选择工程的dylib target, 在other linker flags把报错的的引用移除,下载上面github提供的libstdc++.tbd,libstdc++.6.tbd, libstdc++.6.0.9.tbd保存到电脑,然后在刚才删除的地方把这三个文件的地址引用一下就行了,相当于把原引用指定到你本地。

不报错了 但是安装不了

clean一下再试试?

还是一样的报错 跑不起来

已经可以了 谢谢回复

您方便留个联系方式吗?您是怎么操作的? 我现在mac重装之后 tweak 用不了了

您方便留个联系方式吗

你就用这个 https://github.com/suifengFly1/MonkeyDev.git
这个可以xcode15,但是macos好像他去掉了 不能用