Undeclared identifier error on theos and iosopendev

when i tried to compile my projects on theos its getting these errors … and its occuring on iOSOpenDev too … any suggestion please … :frowning:

1 个赞

replace HBLogError into %c(HBLogError)

1 个赞

where does HBLogError come from?

1 个赞

its from my XXTweak.xm 's NSLog(@…)
its showing in XXTweak.mm file from my iOSOpenDev project

The NSLog method from Logos file is automatically converted to HBLog in main .mm file

then i guess it’s from 3rd party frameworks or implementations, you’ll have to import them manually

1 个赞

I have the same problem! Are you using kirb’s theos?

yea I used it … and copied the included header files from that theos to iOSOpenDev 's header path … now i solved with a way, that is reinstalled theos

1 个赞

Which theos did you reinstall? And can you share the link to the headers you used? iOSOpenDev’s include folder doesn’t have HBLogger.

1 个赞

i just reinstalled kirk’s theos … u shouldnt use theos’ include headers, such as substrate.h, in iosopendev include. i dont know why did that happen … but I got some strange errors that happened before on theos … I think it was headers fragmentation …

have a try:

#define HBLogError NSLog

3 个赞

your method very easy!thank you!

theos/theos works for me though